Auth0 Home Blog Docs

Failed Silent Auth problem



I have problem with Silent Auth. I am using auth0 8.10.1 version. When I call

redirectUri: window.location.href
}, Ext.bind(this.m_auth0CheckSessionCallBack, this, [options], true));

I get “description”: “The specified redirect_uri ‘’ does not have a registered origin.”. I am sending exact uri to checkSession method and exact same uri is configured in clients Allowed Web Origins setting.

Is there anything else I can do?


Based on the information you shared the issue is that you set the exact same URI in Allowed Web Origins setting and that setting expects a web origin.

In conclusion, for an application URL of you need to add the following to allowed web origings Notice that the web origin contains only scheme, host and port (it technically does not contain port in this case because it uses the default one for that scheme); the important part is that there is no path component, in particular, no / at the end.

As an additional note, yes, this is not clear and we aim to improve the validations being done because right now this makes it really easy to get in this situation.