Failed Exchange (feacft) until the client is saved through Auth0 Dashboard MANUALLY

It seems clients created by Management API throw “Failed Exchange: Unauthorized” until the client has updated by Auth0 Dashboard. No data update is required for that. Clicking “SAVE CHANGES” just work.

What I mean is

  1. Create a client through Management API
  2. Create a connection through Management API
  3. Create a user on the connection above through Management API
  4. I cannot use the user above by “Failed Exchange: Unauthorized”
  5. Open the client above in Auth0 Dashboard and click “SAVE CHANGES” without changing anything
  6. Now I can use the user above

I think this issue is the same one as https://github.com/auth0/react-native-auth0/issues/62#issuecomment-546491691

While we use client/connection to keep multi-tenancy, is there any way to avoid this issue without touching Auth0 Dashboard manually? I’ve tried a lot of types of updates through Management API but none worked. Only touching the client through Auth0 Dashboard manually worked.

I’ve found. The reason is that token_endpoint_auth_method is missed when the client had created through Management API.

It seems the client created through the Management API miss some attributes.

The left-side is the client just after created through Management API and the right-side is just after updated through Auth0 Dashboard.

Note that Auth0 Dashboard still shows the client correctly like

Application Details 2020-10-09 01-43-19

So it’s nearly impossible to notice that the attribute is missing from the client.