Extra redirect on silent login after upgrade to v2

Hi, i’m using @auth0/auth0-spa-js and I’ve just upgraded from 1.22.3 to 2.1.3. The documentation to guide the upgrade was great, thanks.

One issue i’m observing is if I refresh the page, it does a silent login. On v1, it’s pretty fast and doesn’t leave my domain. On v2, it seems to take one extra step, and redirects to <mydomain>?code=xxx&state=xxx temporarily before coming back. It also takes longer.

Is there a new option to get the previous behaviour?

Thanks :pray:

Hi, how can we get help? I don’t see any support option.

@tyf thanks for the help on the other post. If I could abuse while I “hold” you, are you able to help with this or ping someone who might be able to? :grimacing:

1 Like

Hey there @tibotiber !

That’s good news - Happy to hear the upgrade was smooth :slight_smile:

That’s a great question, I actually recommend opening up an issue against the SDK itself for this one. I am not aware of any option to mirror the previous version behavior, but I’m also not positive why the extra redirect either. The maintainers of the SDK might be able to provide a better answer.

1 Like

Thanks for the pointer :slight_smile:

Issue opened for anyone who may find this and wants to track it: Extra redirect on silent login after upgrade to v2 · Issue #1277 · auth0/auth0-spa-js · GitHub

1 Like