Error with quickstart code: "invalid or unexpected token"

Hi, this is weird. I’m a longtime fan of auth0 but haven’t worked with it in (literally) a few years. I set out to plug in some authN for an app using some quickstart code but it failed. First I tried with django, then same again with node.js on One Million different browsers in incognito, but it kept doing the same thing. The login prompt would appear, lock would try to launch, and I get a messy error summarized by ‘invalid or unexpected token’ and stuck there.

I did the exact same thing with a new free account and all was well. So is there something with my Very Old account that is messed up here? I can cope and do what I want with my second-string personal email account, but it feels like I cannot create new applications with my ‘old’ account.

Any ideas to use my original account or should I just use my ‘plan b’ email address for auth?

thanks much

  • scott r

Which tenant of yours is it (can also DM me)? Is the quickstart test app available online somewhere?

Does it make any difference if you toggle Dashboard > Applications > Your App > Show Advanced Settings > OIDC Conformant flag ?

Hi - I don’t know if my prior response went out (is there a ‘sent’ message feature in this board?). Just in case it didn’t, here is the response (and thanks for responding, and i apologize for leaving this hanging. Must have not hit the reply button and lost the browser).

  • problem child tenant is called ‘jemez’, and the app label is ‘HighBrow’
  • i was using the quickstart code exactly as downloaded by the ‘download’ button with client values prefilled
  • tried it with django, node.js, and dotnet and got the same answer
  • I tried the oidc conformant flag per your suggestion, but same answer.

Thank you

– scott r