Error is not displayed in auth0 lock, just on url


When auth0 returns an error to my app (for example, if a user hasn’t validated his email), it is returned as a URL parameter and doesn’t display in the lock itself, so the user doesn’t know what’s the error.
Can I change this behavior?

I use auth0-js in reactjs, and the lock is hosted on auth0.

Hey there @dor! I was hoping to find out if you configured your the allowed callback URL? To accomplish this you need to enter in your clients section of dashboard, select the App that you’re using, get in the settings sections and put the url in “Allowed Callback URLs”. Also do you see any errors in the logs related with this failed login attempt? Thanks in advance!

Hi @James.Morrison,

Actually I don’t get any errors and the callback url is configured correctly.
In my case, the error I get is a welcome result - my user hasn’t validated his email and that’s the behavior we want to implement (prevent him from logging in).
Our problem is that the error is not displayed to the user in the auth0 lock - only in the url.

Following up with one of our TSE team members @dor we found that any errors coming from a rule cannot be customized in the lock screen. However, you can redirect your user to a specific error page which is configured in your tenant.

This is found at: Tenant name > Settings- > General → Redirect users to your own error page

Please let me know if you have any additional questions on this matter!

I wanted to follow up with you to see if you have any additional questions regarding Auth0 lock. Thanks!

Hi @James.Morrison,

Thanks for following up.
We implemented it by showing the errors to our users in a different page.
To be honest, that’s a very bad UX… considering that we had multiple problems implementing few trivial features using Auth0, we’re checking our options.


I’m very sorry to hear that @dor, please let me know if you have any further questions or need additional assistance.