Error Client is Not Authorized to Access API

Overview

An error is being received when trying to test a newly created API:

Client is not authorized to access "API URL". You need to create a "client-grant" associated to this API

Cause

The Application is missing authorization, but the linked documentation addresses client grants, not API authorization settings.

Solution

The client is most likely not authorized. This can be corrected by going to Applications > API > Management API > Machine to Machine Applications in the tenant dashboard.