Auth0 Home Blog Docs

Error: Client has not been granted scopes


#1

Hi, hoping someone can help me. I’m using the api to request a token with ‘delete:users’ scope and I’m getting back the ambiguous error below. If I don’t specify any scope i get a token with “scope”:“read:client_grants read:users update:users create:users”. Not sure if I’m missing something on my app side or what, but the scope seems to be available under Auth0 Management API -> Scopes and I don’t have any rules preventing it.

{
“date”: “2018-03-23T16:47:52.620Z”,
“type”: “feccft”,
“description”: “Client has not been granted scopes: delete:users”,
“connection_id”: “”,
“client_id”: “XXXXX”,
“client_name”: “XXXXX”,
“ip”: “XXXXX”,
“hostname”: “XXXX.auth0.com”,
“user_id”: “”,
“user_name”: “”,
“audience”: “https://XXXX.auth0.com/api/v2/”,
“scope”: “delete:users”,
“log_id”: “XXXXXX”
}


#3

:wave: @efarr1

The error message you are getting indicates that you have not granted your API that scope to the client you are trying to use. Can you check if you enabled the scope under API > Non Interactive Clients and selecting the dropdown arrow next to the Authorize switch?


#4

Ah! Thank you so much! Exactly what I was looking for.


#5

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.