Auth0 Home Blog Docs

disable lock in PKCE flow

lock
pkce

#1

So I’ve implemented the Authorization Code Grant Flow with PKCE. It works!

Unfortunately, when users visit the authorization URL, they see the Auth0 lock screen, and this is definitely not desirable. Is there a way to turn that off and have it immediately redirect the user to the Google/Facebook signin UI?

My authorization URL looks like this: https://companyname.auth0.com/login?client=XxXxXxXxXxXxXxXxXxXxXxXx&protocol=oauth2&redirect_uri=http%3A%2F%2Fcompany.redirect.url.io%2Fapi-proxy%2Fv1%2Fpkce&audience=https%3A%2F%2Fcompanyname.auth0.com%2Fuserinfo&scope=email%20offline_access%20openid&response_type=code&code_challenge=XxXxXxXxXxXxXxXxXxXxXxXx&code_challenge_method=S256&state=XxXxXxXxXxXxXxXxXxXxXxXx)


#2

Hey @max1, you can add the connection name in the querystring parameter connection, in this case, for google using oauth2 it would be connection=google-oauth2.

I suggest you to use the /authorize endpoint as it is described in the documentation: https://auth0.com/docs/api-auth/tutorials/authorization-code-grant-pkce

I tested the parameter it and it works with the /authorize endpoint :slight_smile:

Cheers,

Alejo.


#3