Auth0 Home Blog Docs

Disable Authorize App dialog

auth0
api
user-creation
users
clients

#1

I’m using Auth0 for a SPA. I have a Client that is tied to an API and am creating users via the management API. Whenever I create a new user, they always have to Authorize the client to use their account as shown below. Is there a way to bypass this?

![alt text][1]


#2

In the dashboard, enable consent for 1st party client and don’t use localhost for development


#3

Ah, it’s because of localhost. Thank you!


#4

Ah, it’s because of localhost. Thank you!


#5

In case anyone needs the docs: https://auth0.com/docs/api-auth/user-consent


#6

I’ve had the same problem with localhost, but got the answer here. Now I just use my internal domain or network ip address instead of localhost.


#7