Auth0 Home Blog Docs

Cannot update user username in custom database connection


#1

I have a custom database connection set up with “import users to auth0” disabled and usernames enabled.

When attempting to update the username for a user through the api I get the error: “change_username script does not exist”

This appears to be an undocumented db action script.

I just want to change a users username. What’s the workflow? I can’t update my db because the code relies on auth0 having the correct username set. I can’t update auth0 because it relies on an undocumented change_username script. so… ?

I have import users to auth0 disabled. Is there some way just to force that record in auth0 to update and bypass the db script?


#2

Just shooting in the dark… are you able to change the username in the Auth0 profile via the /api/v2/users/{id} endpoint? I’m not sure how that interacts with custom DB scripts, if at all.


#3

nope, unfortunately not. i tried with the api management thingy. it seems if there is a db connection script it’ll get hit no matter what the origin of the request is.


#4

Hi Cory,

Apologies for the delay… was away on vacation!

I just tried changing a username via the Delegated Admin dashboard for a custom DB connected user in my dev environment and it worked. I would suggest opening a ticket with Auth0. I’ve never heard of a change_username script before.

Is tenant you are using in Auth0’s preview environment or their production environment?