Can not get screen_hint to work

No matter what I do, I can’t get my call to /authorize to show the signup screen by default. Using New Universal Login. Passing parameters doesn’t work. Customizing home screen doesn’t work. Frustrating.

Hello @dbinetti,

Can you provide more details? What stack are you using? What does your /authorize call look like?

Hopefully this screen shot is clear:

I’ve started using account linking as well, so my config now looks like this:

  allowSignUp: !config.extraParams.prevent_sign_up,

Sorry, stack is simple Django, so I’m doing a direct call to ‘authorize’ using the requests library.

Similar problem in that I can’t get additionalSignUpFields to work in either Classic or New universal login.

do you need more detail @markd?

Does this help?

Can you post your complete /authorize call?

It is the answer — it’s just not working. Here is the call for the Classic experience. Again, straight from

I’ve tried switching to New Universal, camel casing, snake casing, nothing seems to work.

I’ll try replicating in one of my tenants and get back to you (unless one of the Auth0 folks jumps in with a solution).

The quickest way to check is to use the Auth0 web UI and hit “preview” with the options in the customized login page. I can confirm it doesn’t work through that.

@markd Figured it out. Thanks for helping! For some reason I was on the “Classic” experience when I thought I was on the “new” experience. I’ve now got it down.

Thanks for your help!


Awesome. Glad it’s sorted.

Perfect! Glad to hear that!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.