Auth0 Home Blog Docs

Callback URL mismatch error

I downloaded the node quickstart and was able to get Twitter authentication working fine on http://localhost:3000 after using my own Twitter keys.

I pushed the repo to github and started a container on scalingo.io which auto deploys from github, and added https://mycroft.scalingo.io/callback as the Callback URL both in the container as an environment variable and my auth0 app.

The app pops fine on https://mycroft.scalingo.io but login fails with the following error :-
{
“date”: “2019-07-23T17:43:30.173Z”,
“type”: “f”,
“description”: “Callback URL mismatch. https://mycroft.scalingo.io/callback is not in the list of allowed callback URLs”,
“connection_id”: “”,
“ip”: “146.199.151.137”,
“user_agent”: “Chrome 75.0.3770 / Linux 0.0.0”,
“details”: {
“body”: {},
“qs”: {
“response_type”: “code”,
“redirect_uri”: “https://mycroft.scalingo.io/callback”,
“scope”: “openid email profile”,
“state”: “Rb6i8VwDPFRO4o56mTk1eGdl”,
“client_id”: “VFNCvQe5AcryfcBXkOennA0gqMXkZJZ8”
},
“error”: {
“message”: “Callback URL mismatch. https://mycroft.scalingo.io/callback is not in the list of allowed callback URLs”,
“oauthError”: “Callback URL mismatch. https://mycroft.scalingo.io/callback is not in the list of allowed callback URLs. Please go to ‘https://manage.auth0.com/#/applications/VFNCvQe5AcryfcBXkOennA0gqMXkZJZ8/settings’ and make sure you are sending the same callback url from your application.”,
“payload”: {
“message”: “Callback URL mismatch. https://mycroft.scalingo.io/callback is not in the list of allowed callback URLs”,
“code”: “unauthorized_client”,
“status”: 403,
“name”: “CallbackMismatchError”,
“authorized”: [
https://mycroft.scaling.io/callback”,
http://localhost:3000/callback
],
“attempt”: “https://mycroft.scalingo.io/callback”,
“client”: {
“clientID”: “VFNCvQe5AcryfcBXkOennA0gqMXkZJZ8”
},
“log_url”: “https://manage.auth0.com/#/logs/
},
“type”: “callback-url-mismatch”
},
“session_id”: “OpXy7G_wGlhjQbsK473oLlKA_sDE_I3v”
},
“hostname”: “dev-sfved5r5.auth0.com”,
“user_id”: “twitter|1468336338”,
“user_name”: “Haddock”,
“log_id”: “90020190723174330173304083106854642054780837940080672898”,
“_id”: “90020190723174330173304083106854642054780837940080672898”,
“isMobile”: false
}
I can see that others have had similar problems, but don’t know enough to know what’s relevant. Grateful for any and all suggestions! TIA

Hey there @cjfpainter!

Can you send here the screenshot of you allowed callback URLs? Thank you!

Thanks for getting back!
Here’s the auth0 dashboard
image
and here’s it being set on the node server
image
Hope that’s enough, and thanks again.