AuthHttpInterceptor doesn't add token to authorization header - Error 401 unauthorized - Angular

Hi everyone, I need help with a problem adding token to the authorization header in an Angular HttpClient call, the token doesn’t work and I get a 401 “unauthorized” error.

I followed this documentation to implement the interceptor:

Call an API - Angular AuthHttpInterceptor

I have an AWS API Gateway and a JWT authorizer in the routes. When I disable JWT it works fine and i get the data and when i a do postman test it works too, but when I add JWT to routes in API Gateway it doesn’t work and I get this 401 error. I think that the focus is in Auth0 configuration.
If anyone knows what can i do, I would greatly appreciate it. Thank you.

Hi @antonia7,

Are you seeing the access token in the request? You should be able to look at the Network tab of DevTools and see what is going on.