Auth0 Home Blog Docs

Auth0 Management API missing from dashboard?


#1

I don’t seem to have the Auth0 Management API available in my dashboard. This is all I see:

How do I get access to the Management API?


Bad Audience when calling Management API v2
#2

We are currently investigating what is happening with your tenant.


#3

Hey Auth0 Community,

I’m trying to integrate the Auth0 Management API v2 into my backend service and during my testing, I’m encountering the following error:

{
    "statusCode": 401,
    "error": "Unauthorized",
    "message": "Bad audience: <my API identifier>"
}

I’ve created a Custom API in the API section of the dashboard and set the API Identifier to something like api.example.com, and set up some scopes like create:user.

Next, I created a Machine to Machine Application with is authorized to use the Custom API I created above, and then I enabled all scopes available.

Once that is done, I got the access token on the Test tab for the Machine to Machine Application I just created, and set that in the Management API Explorer. I see the domain set to .au.auth0.com, and all the scopes I require enabled.

I then tried calling the Create User API within the API Explorer, resulting in the above response. From previous posts, it seems that accessing the Management API requires the audience of .auth0.com/api/v2/. However, I am unable to create a custom API with that as the identifier. It just says that the identifier is reserved.

Anyone knows how to solve this?


#4

This is related to the other thread - merging them


#5

Hey Jeremy, thanks for the quick reply! We’re looking forward to start work with the Management API.


#6

To provide an update, there is a bug which allowed you to delete your Management API. We have started the change request process to resolve but it will take some time - to which I don’t have an ETA.


#8

@jonong this change has been applied - can you verify that it is resolved for you?


#9

Yes I see the Auth0 Management API on my dashboard now. Thank you and the team so much for your help!