Auth0 Home Blog Docs

Auth0 for Node Webkit

node
spa

#1

Hi,

Anyone knows please how to enable login from within a Node-Webkit (NW.js) application?

I have successfully completed a login feature for both: web app and Desktop native apps using WPF / UWP. But I really struggle to get this on a Node Webkit app.

I have tried the Auth0-Lock package and didn’t work. I am getting:

Uncaught TypeError: Cannot read property 'protocol' of null
at Object.getOriginFromUrl (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\node_modules\auth0-js\dist\auth0.min.js:8:40041)
at WebMessageHandler.run (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\node_modules\auth0-js\dist\auth0.min.js:8:90848)
at WebAuth.checkSession (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\node_modules\auth0-js\dist\auth0.min.js:8:120370)
at Authentication.getSSOData (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\node_modules\auth0-js\dist\auth0.min.js:8:133973)
at Auth0APIClient.getSSOData (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\lib\core\web_api\p2_api.js:165:61)
at Auth0WebAPI.getSSOData (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\lib\core\web_api.js:85:64)
at Cache.fetchFn (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\lib\core\sso\data.js:17:39)
at Cache.fetch (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\lib\utils\cache.js:31:18)
at Cache.get (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\lib\utils\cache.js:25:10)
at fetchSSOData (C:\JsProjects\ThirdNwJsApp\node_modules\auth0-lock\lib\core\sso\data.js:25:13)

I have also tried using the ‘Auth0-js’ package. I have authorized in the ‘Allowed Callback URLs’ section the following: ‘chrome-extension://jdgkbifmkkkcgglljmlojibojoafmlhi/index.html’ since this is what I have been shown by Auth0 before I have allowed that location.

So, login screen comes up. But after login I get a error page saying 'Oops!, Something went wrong. Clicking underneath on the ‘See details for this error’ link, I get the following

You may have pressed the back button, refreshed during login, opened too many login dialogs, or there is some issue with cookies, since we couldn’t find your session. Try logging in again from the application and if the problem persists please contact the administrator.

Looks like there is a problem specifying / allocating a page for receiving the redirection.

Any suggestion, please?