Auth0 as IdP in tableau wrong signature algorithm

Hi all!

I created and configured a SSO integration using Auth0’s creation flow, but that configuration doesn’t allow me to set the signature algorithm, and it seems like by default, auth0 sets sha1. The problem is Tableau doesn’t supports sha1 as signature algorithm anymore, and it requires to set a sha256 type.

I’m wondering why does Auth0 provides a user friendly flow to create SSO connections but it won’t ever work because of this mismatching configuration.

Does anybody knows If I’m doing something wrong? or is this a known issue?

Hello @guillermo.prados,

Can you provide more details on your setup? A screenshot? Most of the configuration points in Auth0 allow for sha256.

Hi Mark! this was already solved by auth0 support. The configuration doesn’t allows you to change the signature algorithm when setting it up, but they helped me to configure it using the Auth0 apis. Once I changed the signature algorithm everything worked as exected :slight_smile:


Perfect! Glad to hear that!