/api/auth/me returning 502 on deployment

I have deployed a small Next.js application to Netlify and all of the keys appear to be setup correctly. However, for some reason after working for a day or two I pushed some small unrelated code changes, and I can’t get the auth to work on the deployment. Works locally just fine, but on the deployment it gets stuck in the rendering/loading phase and then gives a 502 saying that it couldn’t connect to /api/auth/me.

Repo should be open source here: OOCAZ/HoneyBeeOBT: HoneyBee Oral Bible Translation tool (github.com) and the auth should take place under the app.tsx under source with the login on index.tsx. View deployemnt here at:
HoneyBee OBT
Followed the basic tutorial and it worked for a day, then pushed unrelated code and it broke, so I’m thinking it may have been a miracle that it worked in the first place, tried reverting some code through new commits and nothing seems to be working.

Edit: Upon trying to navigate to other pages it seems to be making my internal API requests to other resource fail too… May be an issue with my Netlify settings and routing, but I’m not sure, any advice would be appreciated greatly. Just weird that it worked for a day and then quit lol.

Please advise.