Action secrets and Database settings handling with deploy-cli-tool

Hi guys, we are trying to to use the deploy-cli-tool to automate the deployment process and have the following problems:

1 .- We have scripts (Authentication - Database (Import users to auth0) - Custom database - Login and GetUser) that use key value pairs in ‘Database settings’, but when we export a tenant that have this value pairs defined, we don’t see them (the key value pairs) in the exported yaml (tenant.yaml). There is a way to set this key value pairs in the yaml file ?

2 - Similary we have an action that use key value pairs from action secrets. In this case we see the pairs in the exported yaml but when we import the yaml in another tenant we don’t see the pairs created. There is a way to get this value pairs imported ?

A little more information about actions:

When we export a tenant (with action secrets) we see them in the yaml file but with value VALUE_NOT_SHOWN. We changed VALUE_NOT_SHOWN to something else and import the yaml file into another tenant but it seems that the secrets aren’t created (we don’t see them listed in the action secrets).

actions:
  - name: postLoginAction
    code: ./actions/postLoginAction/code.js
    dependencies: []
    deployed: true
    secrets:
      - name: codigoSitio
        value: XXXX
      - name: token
        value: YYYY
      - name: dominioPaseServicios
        value: ZZZZ

Any help will be appreciated.

Regards

Hi guys, we update the deploy-cli-tool ( npm i -g auth0-deploy-cli ) (7.0.0 → 7.2.0) and now importing the action’s secrets is working ok.

The values doesn’t get exported but this is not a problem for us.

In regards to the key value pairs in ‘Database settings’ we still doesn’t know how to import they.

Regards

The DB secrets will not be present in the export - Deploy CLI intentionally redacts them. You can add them to the YAML file to import them to Auth0 though. They should go in a configuration object inside the database’s options. Example:

databases:
  - name: "My DB"
    strategy: "auth0"
    enabled_clients:
      - "app1"
    options:
      enabledDatabaseCustomization: true
      configuration:
        key1: "value1"
        key2: "value2"
      customScripts:
        /* redacted */
1 Like

It works perfect!!! Thank you very much!!!

No worries, we’re here for you!