Access_denied error

Hello! I keep getting this error when I try to log in. I can’t seem to find out what the problem is, especially since I haven’t touched anything in Auth0 that should correlate with this error. I’ve reinstalled auth0 and atuh0-react multiple times in my React app. Any direction would be appreciated.

  "error": "access_denied",
  "error_description": "Cannot find module 'auth0@2.30.0'\nRequire stack:\n- /data/io/node18/0297be34-deac-43cc-a107-429ddb3e91cc/webtask.js"

Hey there @joekgilberto welcome to the community!

Do you by chance have any Rules or Actions configured in your tenant?

1 Like

Hello! Thank you so much for replying. I tried adding an Action (I am new to Rules and Actions, this is my first time trying it) like below:

And got this error:

  "date": "2024-01-23T23:18:16.332Z",
  "type": "f",
  "description": "Cannot find module 'auth0@2.30.0'\nRequire stack:\n- /data/io/node18/0995e292-dfea-47bd-9d72-b25757eee713/webtask.js",
  "connection_id": "",
  "client_id": "CLIENTID",
  "client_name": "Blu-Rave",
  "ip": "",
  "user_agent": "Chrome 121.0.0 / Mac OS X 10.15.7",
  "details": {
    "body": {},
    "qs": {
      "client_id": "CLIENTID",
      "scope": "openid profile email read:blu-rays",
      "redirect_uri": "http://localhost:3000",
      "audience": "http://localhost:3000/",
      "response_type": "code",
      "response_mode": "query",
      "state": "aTY5U09UTHV3bHFvSFZOa342dmg5VXdGY0JpZzZqTnlKS05DdTQ5dWNOag==",
      "code_challenge": "N_1kmEg5NpX71_raYy_BqIBQteK03OB904RyFulvh3o",
      "code_challenge_method": "S256",
      "auth0Client": "AUTH0CLIENT"
    "error": {
      "message": "Cannot find module 'auth0@2.30.0'\nRequire stack:\n- /data/io/node18/0995e292-dfea-47bd-9d72-b25757eee713/webtask.js",
      "oauthError": "access_denied",
      "type": "oauth-authorization"
    "session_id": "6SM5wv0J4YdzSBj3iXXk8NGnelGVIY4u",
    "stats": {
      "loginsCount": 45
  "hostname": "DOMAIN",
  "user_id": "USERID",
  "user_name": "",
  "audience": "http://localhost:3000/",
  "scope": [
  "auth0_client": {
    "name": "auth0-react",
    "version": "2.2.4"
  "log_id": "90020240123231816366906000000000000001223372044217668452",
  "_id": "90020240123231816366906000000000000001223372044217668452",
  "isMobile": false,
  "id": "90020240123231816366906000000000000001223372044217668452"

I tried to follow the instructions from your linked post but I can’t seem to make it work- any advice would be appreciated

1 Like

Thanks for following up! I believe the issue is with using auth0@2.30.0 and node18 looking at
Can I Require - I also noticed you have a Rule configured in your tenant called “Netlify Role Management” which is utilizing auth0@2.30.0. I would get rid of the Action entirely (assuming you don’t need it) and update the Rule in your tenant to use a newer version of node-auth0 (4.2.0 being current).

1 Like

This was exactly it- didnt even realize I had this Rule! Thank you so much!!

1 Like

Ahh OK good! Glad that was it :slight_smile: Thanks for confirming.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.