400 error after logging in through Auth0 page

I’ve set the auth0 athentication up in my Next.js app and deployed to vercel. It works on localhost as expected. However, on the live Vercel app, after selecting login from my webpage, it takes me to the auth0 login page, but after I login it gives me a blank page with a 400 GET error. The GET URL is https://{my app}.vercel.app/api/auth/callback? followed by code & state values.

Hi @imran.proco ,

Welcome to the Auth0 Community!

I am curious if you have followed the steps described in this GitHub article to host your app on Vercel. And exactly which 400 GET error you received? I have not tried the steps yet. Ideally, they should work. If you are still receiving the same error, I will test this on my end and let you know.

Hi @lihua.zhang,

Thanks. I did follow those steps listed in the Github article. Please see the screenshot attached with the 400 error.

Hello @imran.proco, Did you fix it?, I’m facing the same issue.

I resolved it by creating a new app on Auth0 specifically for the live URL and it works.