Infinite_token_lifetime cannot be true when app_type is 'spa'

I’m experimenting with using the auth0-deploy-cli to configure our tenants. Scripts that were working a couple of days ago are now failing with the same error.

We are also experiencing this issue today.

13:49:19 2020-12-16T02:49:19.910Z - [31merror[39m: Problem updating clients {“name”:"",“client_id”:""}
13:49:19 Bad Request: infinite_token_lifetime cannot be true when app_type is ‘spa’

Also having this issue, nothing but callback URLs have changed recently.

3 Likes

Same issue here. Trying to add other urls, fail to save with error message:
infinite_token_lifetime cannot be true when app_type is ‘spa’

I have same issue as well for SPA. If I select Native then it works.

Hi,

To resolve this issue, kindly enable and provide value to Absolute Lifetime

Refresh Token Expiration -> Absolute Expiration

1 Like

Facing the same issue all of a sudden. Haven’t changed any setting in the past two weeks, I reduced the expiry time for testing 2 days back. Now when I want to dial it back, I can’t do it due do this.

The issue seems to be gone for me now. I guess it was some bug in the UI :man_shrugging:

1 Like

Is it still there for the rest of you guys?

Still experiencing the issue with auth0-deploy-cli@5.2.1 :

2020-12-16T14:28:38.527Z - debug: Error: Problem updating clients {"name":"My App","client_id":"*********"}
Bad Request: infinite_token_lifetime cannot be true when app_type is 'spa'
at /builds/my-app/auth0/node_modules/auth0-source-control-extension-tools/lib/auth0/handlers/default.js:184:17
at processTicksAndRejections (internal/process/task_queues.js:93:5)

Let me follow up with our engineering teams and check our status page on that. I’ll get back to you shortly!

So from our status page we had a maintenance work done yesterday, more on that here:

but it doesn’t seem to be related. Let me follow up on that with our engineers and get back to you as soon as I have any news.

We are seeing the same error on our deployments this morning.
name: ‘Bad Request’,
Info message: “infinite_token_lifetime cannot be true when
app_type is ‘spa’”,
Info statusCode: 400,
Info requestInfo: {
Info method: ‘patch’,

We are also getting the " infinite_token_lifetime cannot be true when app_type is ‘spa’" error.
This is while trying to change the application from “Generic” type to “Single Page Application” one.

Hey, I’m having the same 'infinite_token_lifetime ’ issue as well. I’m not able to set an application as SPA. Thanks.

I’m wondering if this is not because of refresh token expiration feature that just went general availability yesterday. Can all of you guys do this and let me know if that solved the issue?

This did not resolve our deployment. But this may also be related to the process that we deploy and update IDP settings via a json configuration.
I need to get these meta settings into the json object what are the property names and values to set this configs programmatically? I can see the tenant patch object in the api docs but do not see anything for token rotation https://auth0.com/docs/api/management/v2/#!/Tenants/patch_settings
Properties: Absolute Expiration and Inactivity Expiration. Looking in the console both must be set or the inactivity must be less than absolute expiration

Hey everyone!

I just got the information that the appropriate team is aware of the issue and is working on the fix. As soon as it gets deployed I’ll let you know!

1 Like

The release containing the fix has been rolled out.

3 Likes

Tested and deployments are working

1 Like