Error: Cannot find module 'request@2.56.0' Require stack: - /data/io/node18/******/webtask.js

I am new to Auth0 and am experimenting for a future SPA application I want to build. I don’t know why I am receiving the above error after I have logged in. I have been following the quickstart guides to the letter yet I get this error and in the debug menu I can see that the auth0.user object is undefined. I have tried following the quickstart guides for both Vue.js and React and get the same error for both applications. I also downloaded and tried the sample projects from github and got the same error. I am running the latest version of Node LTS and even attempted to ‘npm install request’.
Any help is appreciated. Thank you!

Hey there @saker132 welcome to the community!

Thanks for the detailed description of what you’re seeing :slight_smile: Do you have any rules and/or extension enabled by chance? I came across the following GH issue:

Hey @tyf thanks for the reply. Unfortunately, I do not have any extensions or actions currently enabled. I have also attempted to use several different node versions, including the current one v20, node 18 and node 16. Still receiving the same error. I am also not sure where to use the work around code in the thread you shared.
Thanks for the help!

I created a new account and after fiddling with settings as discussed in this post
I got it to work. I attempted to apply those same changes to my first account, yet still had issues. I ended up just deleting the tenant and starting over. Which was fine because I had just created it a few days ago anyway. Thanks for the help!

1 Like

Hey @saker132 thanks for the update, and glad you were able to get this sorted :pray: Sorry for the confusion!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.