Why does /authorize not provide the access_token as a regular url query param, but instead with a #

I am trying to do a Silent Authorization GET request and am receiving the access token in my redirect URI with a # instead of the conventional ? query string parameter.

When I look at the documentation this seems to be intentional by Auth0. Why is it intentionally deviating from querystring conventions by not using ? instead of #?


For example the above GET request will respond with the following redirect


But why not return it as a query parameter? I cannot wrap my head around the reason to send it with a #