Where do I set showTerms in lock js config?

Hi there,

I am in the process of configuring our Universal Login form. I am trying to hide the terms by setting showTerms: false. My configuration below is a lightly modified version of the default configuration in the Auth0 dashboard - as it is set in this example the terms are still showing up. It is not clear to me from the docs where I set showTerms, please help.

          // Decode utf8 characters properly
var config = JSON.parse(decodeURIComponent(escape(window.atob('@@config@@'))));
config.extraParams = config.extraParams || {};
var connection = config.connection;
var prompt = config.prompt;
var languageDictionary;
var language;

if (config.dict && config.dict.signin && config.dict.signin.title) {
  languageDictionary = { 
title: 'a title',
    passwordlessEmailInstructions: 'Some text',
    passwordlessEmailCodeInstructions: 'Some text.',
    emailInputPlaceholder: 'you@company.com'
  };
} else if (typeof config.dict === 'string') {
  language = config.dict;
}
var loginHint = config.extraParams.login_hint;

var lock = new Auth0LockPasswordless(config.clientID, config.auth0Domain, {
  passwordlessMethod: 'link',
  auth: {
    redirectUrl: config.callbackURL,
    responseType: (config.internalOptions || {}).response_type ||
      (config.callbackOnLocationHash ? 'token' : 'code'),
    params: config.internalOptions
  },
  clientID: config.clientID,
	domain: config.auth0Domain,
  configurationBaseUrl: config.clientConfigurationBaseUrl,
  overrides: {
    __tenant: config.auth0Tenant,
    __token_issuer: config.authorizationServer.issuer
  },
  assetsUrl:  config.assetsUrl,
  allowedConnections: connection ? [connection] : null,
  rememberLastLogin: !prompt,
  language: language,
  languageDictionary: languageDictionary,
  theme: {
    logo:            'https://url.com',
    primaryColor:    '#FFFFFF',
  },
  closable: false,
  showTerms: false
});

lock.show();

If it helps I want to hide section that says: “By signing up, you agree to our terms of service and privacy policy.”

Screenshot 2020-09-21 at 18.37.41

The reason for this seems to be that Auth0LockPasswordless is not respecting that option; I personally find this to be an issue as I see no reason for that option to not be respected for passwordless. I opened (https://github.com/auth0/lock/issues/1927) to report this situation, you should follow that GH issue and/or comment about your use case.