Using non-default App ID & App Secret

hello -

it would appear that with Auth0, if we want to use a node application, the only way it works properly is to use the Auth0 default App ID and App Secret. when i tried to use my own given to me by Google & Facebook, my node app would not work.

then i deleted my App ID & App Secret, and my app was working fine.

is this expected behavior? when i ran the “try it” feature with both my id/secret and the default one, both gave me very similar results:

“sub”: “google-oauth2|114113878629589347134”,
“given_name”: “Mark”,
“family_name”: “Smith”,
“nickname”: “mark”,
“name”: “Mark Smith”,
“picture”: “”,
“gender”: “other”,
“locale”: “en”,
“updated_at”: “2020-03-04T17:31:30.935Z”

is this expected behavior? i have no issues using the default id/secret’s but am surprised they did not work as expected.

thank you.

Hi @edwardsmarkf,

You should definitely use your google/facebook dev keys, there is some functionality that will not work with auth0 dev keys. How are they not working? Specific error messages?

Let me know,

Thank you so much Dan - we think it might be related to the grant-profile npm module. i wont have time to test this out anytime soon, but i raised the issue with the author.

And thank you for your prompt reply.

This is obviously a third-party package and Auth0 does not maintain it nor do they support it. But this is used with FeathersJS, the best framework ever created. Therefore its important that the author look at it.

i would be curious to learn what the missing functionality is.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.