User already exists when creating a new user

I have seen similar issues in the community but none had an answer to this particular problem. Here is some context to our setup:

We have an active custom connection that is setup to migrate users when they loging

Now I am testing how to create new users that are also on our side totally new. So I called the create user endpoint of the management API and got the response that the user already exists.

Now I cannot find nor delete the user in any way. I tried finding the user on the management portal. I tried finding the user via the API and I also tried deleting the user. In all those case the response is that the user does not exists except if I want to create it?

Does anyone know what could be an explanation for this?



I have thought about this and was wondering whether I should have different connections:

  1. to migrate legacy users into Auth0: custom DB with migration turned on
  2. to add new users immediately in Auth0: no custom DB

If this would indeed be the way forward, how do you then complete the migration when all legacy users are migrated into Auth0?