Someone created an Auth0 account using my email

Hi everyone,

I’m not super tech savvy, so please bear with me! :slight_smile:

A couple days ago I received a general informational email from Auth0. I thought this was odd because I’ve never used Auth0 before (I don’t even know how to). At the bottom of the email it said “The notification applies to your Auth0 tenant [name of “my” tenant] in region US” as well as “You are receiving this message because you are an administrator of an Auth0 tenant.” Strangely, the name of the tenant happens to be the name of my business.

I figured there would be some sort of account that I could login to find out what’s going on. So I tried a password reset using my email address thinking an account would be found. But there wasn’t because I never received a password reset email.

I have no idea how my email account got linked to an Auth0 tenant. Like I said, I don’t even know how to use Auth0. And I’m the only person who uses my business email account. I’m not sure if this is relevant, but last year there was an issue with someone/something setting up some kind of API/OAuth/federated login access to my GSuite account (my email account is set up through Gsuite).

How do I delete the Auth0 tenant? And is there a way to determine how/when/who established it in the first place?

Thank you, and again, sorry for my lack of tech savviness!


Have in mind that in order to signup for the Auth0 service it’s possible to authenticate/login through different methods:

  • email/password specific to Auth0 (implies a signup with password).
  • social logins (like Google, Microsoft and others).

Given you mentioned that you requested a password reset and no email was ever received a possible explanation would be that the reason that email address is associated with an Auth0 tenant is that you in the past may have logged in (signed up) using the social account method.

If you think that may have happened you can try to login through the Google social connection button in the Auth0 login page and confirm if there’s any tenants associated with that Google user identity. If there are you would be able to delete the tenant yourself; if there are no tenants you be asked to create one (which you can skip), but I’m afraid the explanation would be something else in that case.

Yes I tried that method of logging in/signing up and there wasn’t any existing tenant associated with that Google user identity. It simply prompted me to create a new user account.

That complicates things; in addition any analysis on our side is also constrained by what information you can provide in a verified way and I’m afraid a public forum may not be the best way for such an analysis. If you haven’t considered yet you could consider creating a new trial tenant so you can open support tickets and discuss this through the support center.

Okay, I will do that. Thank you for taking the time to help me out!