Passworldess login: How to send username (phone_number) through API to Auth0 Database?

EDIT 18.4.2020: Found the problem through postmate and webhook.site. The chatbot service I used sent two hidden values that I was not aware of, these values (ip, www) made the auth0 refuse the data. Asked the chatservice to edit the webhook so will get it working. Will leave this here on the forum if somebody has the same problem. In general I would say there would be need for a simplified tutorial by Auth0 how to add phonenumber login only type to a website with option to send the phone number from external service

Original 17.4.2020

Greetings, very impressed by Auth0 platform so far. Help with finalizing my first project much appreciated (so others can also find answer here for configuring passworldess SMS OTP)

  • Despite not having prior experience with login systems, I have successfully embedded the login screen to my website project thanks to the documentation on this forum.
  • I have also disabled Auth0 signups from the phone login page as I have generated the username = phone number elsewhere (ready to be sent through API to Auth0 if I have the correct details)
  • The login with just phone number & SMS OTP works now successfully, however my remaining challenge is to import the previously collected username = phone number to the Auth0 database

This is my current set up for sending the data from collect.chat service (webhook)

On postmate I get error #400 asking for email

This is a bit conflicting to what is stated in the api documentation (only connection is mandatory rest depend case-by-case) https://auth0.com/docs/api/management/v2#!/Users/post_users

Background info on my settings:

  • Dashboard>Connections>Database>“Username-Password-Authentication” > Sign-ups allowed
  • Dashboard>Connections>Database>“Username-Password-Authentication” > “Require username” turned off
  • Dashboard>Connections>Passwordless>SMS OTP > Sign ups disabled
  • Using fresh Bearer token (doesn’t give #401 in postman)

What should be the correct API configuration to succesfully send just phone_number to Aut0 DB so it can be used as login credentials?

All guidance much appreciated!

Hi @Auth0Newbie,

Thanks for posting a resolution to your initial post. It sounds like you have it solved, but if you don’t please don’t hesitate to ask more questions. I am happy to continue in this thread.

Thanks,
Dan

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.