Password Reset Email not being recieved by Microsoft 365 Accounts

We’re trying to implement the password reset flow, using https://[DOMAIN] . When I tried using this endpoint however, i get the “we’ve sent you an email” response, but no email appears to be recieved.

Poking around more, I’ve worked out that it appears to be only affecting Microsoft 365 hosted emails. I’ve tried this with multiple emails on my company domain, as well as a developer 365 Tenant. My personal gmail, and an address hosted on a custom domain however work just fine.

Now the email is hosted by a third party- specifically Ionos - which might be causing the issue. However all of these addresses are able to recieve messages from the account set up in the auth0 tenant. I’m aware that there are a number of other examples of this on the forum, but I can’t seem to find a fix amongst them. The logs just show that the email has been sent, so it seems to be getting lost somewhere

As a workaround, I’ve been able to manually implement sending the email through the same SMTP setup in our backend API using python and smtplib. This seems to be recieved just fine by 365 addresses, so documenting that here for anyone else with the same issue. Not ideal however, and still not sure why sending it through auth0 has this issue. Hope this can help someone!