Non-existent user displayed in the users list and can't be deleted

Hi there!

Some user is displayed by Email in the list of users, but if I try to open its account I get a message that user doesn’t exist. If I try to remove it from the list, it stays there after this action.

How can I solve this issue?

If you tenant is located in the US-1 region this may be related to the incident on Monday (https://status.auth0.com/incidents/1mndgj0n9fzb); can you confirm if you tenant is indeed in that region or not as that would influence analysis of the situation.

1 Like

My tenant is located in US-1 exactly, and I created that user previous Monday (26 Oct). So, you described my situation. Confirm!

1 Like

@jmangelo So, how can I solve it? Can you help me with that?

As a possible quick fix attempt, have you tried to perform a DELETE user operation through the Management API (https://auth0.com/docs/api/management/v2#!/Users/delete_users_by_id)? I believe that as part of the resolution of that incident a full re-index of user search will be completed, but due to the sheer volume of data a full re-index can take some time, hence my suggestion above.

If the delete does not work I would also try creating a new user with the same identifier in order to force an individual re-index of user search for that user identifier. I’m afraid I don’t have a particular user record in this situation so can’t confirm if any of these suggestions would resolve it ahead of a full re-index.

Unfortunately, nothing helped.

  1. I made the request for removing user by ID using Auth0 API. That ID I got from developers panel in the browser, because I couldn’t open an account page as I said in my issue description. I got 204 status OK which means that user is deleted successfully, but user remained in the list.
  2. I tried to recreate a user from scratch using the same Email, but Auth0 system created a user with the same Email and in the same connection. How is it possible?

@jmangelo Any thought?

Guys, the issue is not solved yet! Any reaction? :cry: This is an internal issue of this service…