IIS SMTP server not working as Email Provider for Auth0

We are trying to configure SMTP Email Provider in Auth0, the SMTP provider that we are using is IIS SMTP server, which is correctly configured on the ports suggested by Auth0. The IIS SMTP server is TLS enabled >=1.0 as required by Auth0
The server resides behind the firewall and all the Auth0 IP’s are bypassed, when trying to send email from Passwordless Email Test, we are able to see the request arising from the Auth0 ip addresses, but however emails are not sent.

The logs under monitoring shows failed sending notification with following JSON (hiding the valid email for security purpose)

“details”: {
“email_type”: “try_provider_configuration_email”,
“to”: “email@email.com”,
“error”: “129529942624128:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:…/deps/openssl/openssl/ssl/record/ssl3_record.c:332:\n”
},

We tried a variety of setting on IIS SMTP server and are able to correctly use it with other applications under TLS protocol correctly. Upon investigating this issue, it seems like connection error that might be happening from Auth0 to IIS SMTP

Any ideas, suggestions on potential fixes?