Google OAuth Not Returning Token/User Data, Local Strat Working as Expected

Please include the following information in your post:

  • Which SDK this is regarding: @auth0/auth0-react": “^1.0.0”

  • SDK Version: Assuming latest

  • Platform Version: React 16.13.1

  • Code Snippets/Error Messages/Supporting Details/Screenshots:

    const {authData, setAuthData } = useContext(AuthContext);
    const {
       isAuthenticated,
       loginWithRedirect,
       getAccessTokenSilently,
       logout
    } = useAuth0();
    
    const handleLoginClick = async (e) => {
      await loginWithRedirect();
    };
    
    useEffect(() => {
      const fetchAuthData = async () => {
      	let token = undefined;
      	let userInfo = undefined;
    
      	if(isAuthenticated){
      		token = await getAccessTokenSilently();
      		userInfo = await axios.get('/api/userAPI/userInfo/processUser', {headers: {Authorization: 'Bearer ' + token}});
      	}
      
      	await setAuthData({
      		token: token,
      		user: userInfo ? userInfo.data.userData : undefined
      	})
      	
      }
      (async () => {
      	await fetchAuthData();
      })();
      
     }, [isAuthenticated]);
    

Last Friday when I was last working on my project, the source above worked for both login options, Google and Username/Password. Today, only the username/password is working. Today, when you click on the “Sign In with Google” button, it does not give the option to choose the account to sign in with per usual, and just redirects back to my React app without passing in the token or user information. However, as I said prior, I am able to log in using a user with username/password.

It may be worthwhile noting, I’m running with dev Google keys in my Auth0 configuration. Could this possibly be a service disruption? Has anyone had issues like this before?

Will happily give more information if needed!

I should also probably mention that the Google login is logging in my Auth0 dashboard, but the Google information is still not returning back to my client as it was at the end of last week, with not subsequent code changes that I can see in my versioning.