Enterprise Connection not saving

Problem statement

We are trying to update an Enterprise connection. When we hit ‘Save Changes’, nothing happens. There is no error, and the connection is not saved.

Cause

This is likely due to the Home Realm Discovery ‘Identity Provider domains’ field having an unsupported value.

Solution

Check the Home Realm Discovery ‘Identity Provider domains’ field and make sure it’s in the format of the comma-separated list of domains. E.g. testone.com, testtwo.com.