Auth0 Home Blog Docs

Disable Authorize App Dialogue Box

Question: Disable Authorize App Dialogue Box

Answer:

Using localhost as your development environment can cause this dialogue box to appear. Consent cannot be skipped on localhost, as it is never a verifiable first-party client.

During development, you can work around this by modifying your /etc/hosts file to add an entry such as the following:

127.0.0.1       myapp.example

Similarly, you cannot skip consent (even for first-party applications) if localhost appears in any domain in the Allowed Callback URLs setting (found in Dashboard > Applications > Settings). Make sure to update Allowed Callback URLs , and the callback URL you configured in your application, to match the updated domain-mapping.

Supporting Documentation:

Documentation: https://auth0.com/docs/api-auth/user-consent