Database login script

Hi there,

I’m a new auth0 user.

I configured a custom auth0 action script. I develop with a local database. When I test the script, everything is fine, the user is valid, and the password also.
But now, when I try to login with the universal login, I get the error in the log ‘Wrong email or password’.
I can’t understand why the script would be working when using the testing database action script feature, and not when using the universal login.

Any ideas ?

I can share more details if you need for further investigation.

Thanks a lot folks.

Hi @amaury ,

Welcome to the Auth0 Community!

One possible reason for getting the " Wrong email or password" error is that the application is not connected with the database where the user is stored. Could you please check under the connection tab and confirm if it’s corrected with the correct database?

If the connection is correct, please DM me your tenant, connection/local database, action, and sample user email and I will look into it further Thank you!

Hi @lihua.zhang,

Thanks for reaching out. I confirm the connection is connected to the right database.
The tenant name is ‘greenly-dev’. The database is ‘database-dev’.
A user email:
I may precise something: for the standard example (db connection), the connection is working, and the universal login as well. We have an impersonification feature that I migrated to the custom db, to allow our connection to be migrated to auth0. This is the feature that is not working.

I think I have identified my issue. Is it possible to always call my legacy datastore (through the login script) ?. The script seems to be trigger only if he does not exist in auth0 datastore.

Thank you for providing additional details.

Your custom database has “Import Users to Auth0” turned on. With this feature enabled, when a user logs in, it will first check the Auth0 datastore. If the user does not exist, it will look up the custom datastore and then add the user to the Auth0 datastore. And the next time the user tries to log in, it will check the Auth0 datastore only.

If you only want to use the custom datastore, try turning off “Import Users to Auth0”.

One concern is that your tenant is free, which does not support the custom database feature. Your custom database was created during the trial, which ended already. In this case, I am not sure if turning off “Import Users to Auth0” will solve this issue.

If you are interested in upgrading to another plan that supports the Custom Database feature, please check the Pricing - Auth0 page or contact our Sales team.


This topic was automatically closed after 11 days. New replies are no longer allowed.