Custom DB gives error "please verify the provided email/username or password"

Problem Statement

During an operation related to a user from a custom database connection, a “please verify the provided email/username or password” error is thrown.

Symptoms

  1. There is a custom DB with Import Mode turned on.
  2. User tries to perform an action such as reset password
  3. You get an error similar to: "DB Get user Custom script: please verify the provided email/username or password."

Troubleshooting

The error can be found by searching logs_users* stash in applogs for the string “please verify the provided”.

When debugging, please verify that the connection is a custom DB in import mode.

Cause

This can happen when a different email address is sent for a particular user ID when there is already a record of one email address. This could happen, for example, when the user’s email address changes in the legacy DB, but there is already a shadow profile in Auth0 with the old email.

Solution

The Management API v2 Delete a connection user endpoint can be used here to clean the shadow user.

This is one of the very few use cases where this endpoint is needed.

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