Auth0 Home Blog Docs

Cors - we're sorry, something went wrong when attempting to log in

signup
database-connections
#1

I have configured the database connection, everything was working fine, until one day it started throwing errors when people attempt to signup

and when I check the console, I see the following error
WE’RE SORRY, SOMETHING WENT WRONG WHEN ATTEMPTING TO LOG IN.

Access to XMLHttpRequest at ‘https://mycompany.auth0.com/usernamepassword/login’ from origin ‘http://abc.mysite.xyz’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

Now I have added the website to
Allowed Origins (CORS) section

it still has errors

need help

#2

Hey there @mak2!

Firstly could you let me know if you’ve changed something in the meantime between ot was working and it started throwing such error?

#3

Nothing changed from my end, but getting this CORS error.
Not sure if anything setting has changed, but now I have gone and added the domain in the CORS section as well, still no effect

1 Like
#4

Thanks for expanding on that! I’ll dig into it and let you know once I find something!

#5

Thank you, do let know if you any info from my end

#6

Sure I need to reproduce it and discuss internally! Will get back to you as soon as I have news to share!

#7

Hi
How is that i can get a support on this, this issue is stopping me from release,
not able to use database registration for users

#9

Hey there!

Sorry I haven’t assigned myself to this and it completely got away from my attention.

Can you let me know more context around it what database you use, what are potential steps you think I need to make to reproduce it, anything that can be helpful for me debugging it?

Thank you!

#10

I am using Auth0 database connection, there is no Custom database.
it used to work, but now a days its not working, it throws the above error, I can send you the link as well where you can see by yourself

let know what info you need

#11

Ok i think I’ve got everything for now let me try to dive into it and get back to you with the news!

#12

Hey again!

I’ve started discussing it internally and can you provide us with HTTP trace containing all the requests since accessing the application to the problem?

Thank you!

#13

This is waht I see in logs
{
“date”: “2019-03-22T11:26:03.497Z”,
“type”: “fco”,
“description”: “Origin http://m300.wajooba.xyz is not allowed. Behavior used for check: WEB ORIGINS”,
“connection_id”: “”,
“ip”: “110.227.204.136”,
“user_agent”: “Chrome 72.0.3626 / Mac OS X 10.14.0”,
“details”: {
“xhr”: false,
“method”: “OPTIONS”,
“origin”: “http://m300.wajooba.xyz”,
“headers”: {
“x-forwarded-proto”: “https”,
“x-forwarded-for”: “110.227.204.136, 172.25.2.65”,
“host”: “wajooba.auth0.com”,
“x-forwarded-port”: “443”,
“x-amzn-trace-id”: “Root=1-5c94c64b-57583ec2fe238a56e89cbd91”,
“pragma”: “no-cache”,
“cache-control”: “no-cache”,
“access-control-request-method”: “POST”,
“origin”: “http://m300.wajooba.xyz”,
“user-agent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36”,
“access-control-request-headers”: “auth0-client,content-type”,
“accept”: “/”,
“referer”: “http://m300.wajooba.xyz/”,
“accept-encoding”: “gzip, deflate, br”,
“accept-language”: “en-US,en;q=0.9”
},
“host”: “https://wajooba.auth0.com”,
“originalUrl”: “/dbconnections/signup”
},
“hostname”: “wajooba.auth0.com”,
“log_id”: “90020190322112603497469719864495929658769977486291005197”,
“isMobile”: false
}

#14

Thanks @mak2! Let me investigate this and get back to you soon!

#15

hi Any updates on this?

#16

Hey there @mak2!

That log does not seem to have nothing to do with /usernamepassword/login which is the endpoint mentioned in the initial message

That log should be resolved by ensuring proper client configuration.

#17

hi

I am confused on what needs to be done, let know what needs ot be done, as we have not changed anything from out end

#18

I love your product, and would like to stick to it, but if there is no way for me debug the Issue we are gated on going production for it