Can't seem to clear session/cookies from Auth0 universal login page

I’m having an issue with the universal login page using Elixir with Phoenix. After following this tutorial, we got the login working using Auth0 Universal Login:

We initially redirect the users from our application to the Auth0 Universal Login page.
What’s happening is that when we logout of the application, clearing the session and cookies using Phoenix, we are also doing a GET request to the logout endpoint, as described here:

And after that, we redirect to the initial application page, which in turn redirects to the Auth0 Universal Login.
This is correct up to this point, the problem is that we can’t even see the Universal Login page since the user gets logged in using the same credentials previously used.

I tried calling the logout endpoint with and without the application client_id, and with the federated parameter as well, but this still doesn’t fully clear the session/cookies on the Auth0 Universal Login.

Why could this not be working? I need to clear the Auth0 session/cookies so that if the user wants they can use another account to login, and not always the previously used.