Can't find SSO connection in the dashboard

Hi, We have had a customer who is using some sort of SSO integration for years. Now they are asking us to make changes to this configuration but we cannot find it in our tenant dashboard.

Normally I would look under “SSO Integrations” but it’s not there, next I would look under “Connections” but I can’t find it there either…

We frequently fetch a json backup of our entire auth0 configuration, inside this backup I am able to locate the configuration under “connectionList”

This is what it look like (I have replaced the customers name with ‘qqq’):

"connectionList": [
  {
    "id": "con_h6OcSOMEIDNks",
    "options": {
      "scope": "openid allatclaims",
      "scripts": {
        "fetchUserProfile": "function(accessToken, ctx, cb) {\n  function atob(str) {\n    return Buffer.from(str, 'base64').toString('binary');\n  }\n\n  var parsedToken\n  try {\n    parsedToken = JSON.parse(atob(ctx.id_token.split('.')[1]));\n  } catch (e) {\n    return cb(e);\n  }\n\n  var profile = {\n    user_id: 'iss:' + parsedToken.upn,\n    email: parsedToken.email || ('No email returned for ' + parsedToken.upn)\n  };\n\n  // Debug with this:\n  // profile.family_name = JSON.stringify(parsedToken);\n\n  return cb(null, profile);\n}"
      },
      "tokenURL": "https://sts4.qqq.com/adfs/oauth2/token/",
      "client_id": "UUID",
      "authorizationURL": "https://sts4.qqq.com/adfs/oauth2/authorize/?resource=https://our-company-name.eu.auth0.com"
    },
     "strategy": "oauth2",
    "name": "qqq",
    "is_domain_connection": false,
    "realms": [
      "qqq"
    ],
    "enabled_clients": [
      "DJRgQFLpsomeiduwntR6yEvwD159Kd",
      "6YvFjKeMsomeidCh2KrC5zOFiHj3TVE",
      ......
    ]
  },
]

I hope that based on the way this JSON look that someone can guide me now how to get to this in the dashboard.

Thanks

Looks to me like it should be under Connections -> Enterprise, probably under ADFS. Do you have no ADFS connections set up?

Thanks for your reply. Unfortunately both sections are empty. In fact I’ve looked at every single sub page of Connections -> Enterprise and haven’t found it.

Can you confirm you are in the right Auth0 tenant? Do the client IDs in the output above exist in that tenant?

You can try going directly to the URL for that connection, which should look something like:

https://manage.auth0.com/dashboard/eu/[our-company-name]/connections/enterprise/adfs/con_h6OcSOMEIDNks/settings
1 Like

Ok, I was able to stitch together an url like you showed, and strange enough it does lead to a page with the correct customer initials… Here is have crossed them out but for the sake of my previous example, imagine behind the crossed red marking that there would be ‘qqq’

But everything else is left empty, and when i click the back button I come back to the empty ADFS page where this one is not listed.

Sounds like a bug to me. One of the Auth0 folks should be able to look into it.

@konrad.sopala @James.Morrison

1 Like

Following up on this front @rasmus1, can you direct message me your tenant name when you get a chance? I’d like to take a deeper look at what may be going on here.

2 Likes

Following up on this front @rasmus1, from investigating on my side I am unable to recreate the error. Are you still experiencing the challenge? If so, I would recommend opening a support ticket with our support team so they can take a closer look at it with you to see if we can recreate and document what may be going on here. Please let me know if you have any questions on this!

Hello James. The problem stil persist, I have opened a support ticket.
We created a dummy test ADFS connection which shows up in the list:

But the connection described in post 1 is still not displayed in the dashboard.

When I navigate to it with the manual stitched url I am able to get to a page in the dashboard where part of its configuration shows…

When we fetch a json backup from: https://${auth0.domain}/api/v2/connections
We also get now both the newly created dummy connection and the original one in the response, only it does not show up in the manage.auth0.com dashboard.

Hi all, following up on the back of a support case raised for this.

The issue here was the connection was a “Custom Social Connection” - https://auth0.com/docs/extensions/custom-social-extensions
The presence of a fetchUserProfile script and strategy ‘oauth2’ were indicative of this.

Custom social connections do not show up in the dashboard, however they will show when polling connections via the Management API.

To manage them in the dashboard, please open the Custom Social Connection extension to see the GUI for these types of connection.

4 Likes

Thanks @sgo for following up this front!

Thanks for the rapid support. Highly appreciated!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.