Auth0 Home Blog Docs

Cannot use Webtask CLI in other tenants

webtask

#1

Hello all,

We use the GitHub Deployments extension, but want to change the branch used in our development tenant. Since there does not seem to be any way to change the GitHub branch after the extension has been setup, I thought I would be able to delete the extension and re-install it. It seems like the only way to uninstall the extension (please correct me if I am wrong) is through the Webtask CLI. However, I cannot initialize the Webtask CLI for the development tenant.

When I run the wt init --container "{tenant}" --url "https://sandbox.it.auth0.com" -p "{tenant}-default" --auth0, command, it fails on authentication with this error:

The given subscription does not support the Webtask CLI.

and the auth response from Auth0 says Service not found: https://auth0-extend.com/deployments/auth0-us/containers/{tenant}.

The wt init command worked fine in our main Auth0 tenant.

Any help would be much appreciated!

Thanks,
Walker


#3

hi @chronowalk,

Sorry to hear you are encountering issues. Luckily you can modify the branch that the GitHub Deployments extension uses right in the management dashboard.

Here is a quick gif showing how to do it:

Does this work for you? If not can you give me some details on how it is failing for you?

Thanks,
Bobby


#4

Bobby,

Thanks very much. Wow – apologies for not noticing that option in Installed Extensions. Much easier than deleting and re-creating!

Thanks,
Walker


#5