Auth0 Home Blog Docs

Cannot switch from classic to new beta

universal-login
beta
#1

Hi

I’m starting out integrating Auth0 into an instance of the javalin microframework.

I’ve grabbed the pertinent snippets of code to generate the authorize url which javalin then redirects to. I’ve also selected the new beta experience in the Universal Login section of the tenant dashboard. However, I’m still getting the classic login - what am I doing wrong?

Many thanks

Ben

#2

Hi Ben,

The two reasons I can think of:

  • After selecting the new experience, you need to click the “Save” button.
  • You have a customized HTML page for Login (go to the Login tab, see if the “Customize Login Page” toggle in ON). If that’s the case you should also see a warning in the Universal Login settings tab indicating so.

Please let me know if it helps.

Thanks,

Andres

#3

Hi

Thanks for such a prompt reply. I checked both of these settings that you suggested and they look to be set as you suggested (Universal Login defaults to beta and the Login customisation is defaulting to off when I view the pages int he dashboard).

I’m using the Auth0 com.auth0:mvc-auth-commons:1.0.5 library to build the authorize url as per the Auth0 published doco. Is there a switch somewhere in there for pointing my web app at the beta universal login?

Many thanks

Ben

#4

Hi Ben,

The url is the same /authorize?client_id=… . If you tenant is configured to use the New experience it will redirect to /u/login. If it’s configured to use the Classic one, to /login.

If you mind sharing with me the your auth0 tenant name, I can check if I see something odd.

Thanks,

Andres

#5

Hi Andres

Here is our tenant name: staging-coreillumination

Many thanks

Ben

#6

Hi Ben,

We were able to identify the issue. There are two fields in the Application data we use to identify if the page was customized, a boolean one and the content of the HTML page. For some reason (we assume that it was because you set the custom HTML through API), the boolean field is not set.

If you try enabling custom HTML for the login page, saving, disable it, save it, it should be saved consistently and you should be able to see the New Universal Login Experience page for login.

Thanks a lot for reporting this, it was helpful.

Let me know if it helps.

Thanks,

Andres

#7

Thanks Andres - do you mean the Save Changes button on the Login tab of the Universal Login? If so I can only save changes if I have modified the HTML when custom html is enabled. So do you mean:

enabling custom HTML for the login page
Make a change to html
save changes
disable it

Thanks

Ben

#8

Yep, that :wink:

Thanks,

Andres

#9

Seems to be working - thanks :clap:

1 Like