Cannot authenticate with custom scope in React (won't show consent dialogue)

  • Which SDK this is regarding: auth0-react
  • SDK Version: ^1.3.0
  • Platform Version: Node v15.4.0
  • Code Snippets/Error Messages/Supporting Details/Screenshots:

I am trying to get a token for with the read:users permission using the React SDK. Whenever I call getTokenSilently({ scope: readUsers, audience: ... }) I get a consent required error. The React App is first party and I do not have localhost anywhere in my approved URLs & I am running the app from I have also made sure to assign the scope to the user in the dashboard as well as enabling RBAC and checking the Add Permissions in the Access Token switch. In addition, I have tried logging in with Allow Skipping User Consent both checked and unchecked. After all of this I still can’t get the app to even request user consent for the read:users permission. Does anyone have any suggestions on things to try or see anything that I might be missing?


Hi @hmerzin,

Welcome to the Community!

Skipping consent is only allowed for verifiable first-party apps. You can get around this by modifying your /etc/hosts file. Here is a doc that explains it in further details.

If this doesn’t work then let us know and we can continue to troubleshoot.

Hi @dan.woda,

Thanks for the reply! Actually, I am trying to get the get the consent dialog to show up for an app that is first party (I switched off the Skip Ask User Consent toggle in settings).


The user that is trying to get the token silently, have they accepted the consent dialogue? You can see their allowed apps in the dashboard.

Yes, they have given permission, but I still can’t seem to get the token with the scope

Can you DM me the users name/email and the tenant? I’d like to look at the logs.

yes, I just sent one over. Thank you!