Authentication API - Social Login

Based on documentation here:
When “connection” parameter is set, then redirect should happen directly to the social network.

But still even with “connection” set to “google-oauth2”, I’m ending up getting the Auth0 page.

The goal is to be redirected directly to the Google login “without” showing the Auth0 page to end-user.

What could be wrong?


Hmm that’s a bit weird. Can you go to your Auth0 Dashboard-> Connections->Social and see if this connection is visible?

Thanks for reply, @konrad.sopala

I can see Google connection is enabled/visible

Got it. What happens when you click accept on the screenshot you sent recently?

do you mean this one?

Yes, what happens when you hit Accept here?

it redirects me to the callback url (e.g along with expected parameters.

And just to make sure, we are on the same page,
I’m expecting to get this:

instead of this:

Gotchya. Yep I know what you expect. Let me research that and get to you as soon as I find something!